WWW.REFERATCENTRAL.ORG.UA - Я ТУТ НАВЧАЮСЬ

... відкритий, безкоштовний архів рефератів, курсових, дипломних робіт

ГоловнаІнформатика, Компютерні науки → Лінійна оптимізацій на задача - Реферат

Лінійна оптимізацій на задача - Реферат

5.4 - Вимоги до складу металів
сплав вимоги до складу матеріалу сплав вимоги до складу матеріалу
А Не більше 70% металу І В Від 50 до 80 % металу ІІ
Не більше 30% металу ІІ Не менше 20% металу ІІІ
Не більше 50 % матеріалу ІV
Характеристики і запаси руд, з яких отримують метали I, II, III і IV, зазначені в табл. 5.5.
Таблиця 5.5 - Характеристики і запаси руд
Руда Максимальний запас, т Склад, % Ціна, $/т
І ІІ ІІІ IV Інші компоненти
1 2000 20 10 30 30 10 35
2 4000 10 30 20 30 10 50
3 1000 10 50 10 20 0 30
Нехай ціна 1 т сплаву А дорівнює $220, а 1 т сплаву в - $250. Необхідно максимізувати прибуток від продажу сплавів А и В.
Позначимо х1А, х2А, х3А, х4А (х1В, х2В, х3В, х4В) кількість I, II, III і IV металів, що використовуються для одержання сплаву А (В), а уі, де і?[1; 3] - кількість використаної і- ї руди.
Тоді математична модель даної задачі має вид:
Максимізувати:
Z=220(х1А+х2А+х3А+х4А)+250(х1В+х2В+ х3В+х4В)-35yl-50y2 -30у3
при обмеженнях:
- на склад сплавів:
х1А?0,7(х1А+х2А+х3А+х4А),
х2А?0,3(х1А+х2А+х3А+х4А),
х2В ?0,5(х1В+х2В+ х3В+х4В),
х2В?0,8 (х1В+х2В+ х3В+х4В),
х3В?0,2 (х1В+х2В+ х3В+х4В),
х4В? 0,5(х1В+х2В+ х3В+х4В).
- на характеристики та склад руд:
х1А+ х1В ?0,2 у1+0,1 у2+ 0,1у3,
х2А+ х2В ?0,1 у1+0,3 у2+ 0,5у3,
х3А+ х3В ?0,3 у1+0,2 у2+ 0,1у3,
х4А+ х4В ?0,3 у1+0,3 у2+ 0,2у3,
- на діапазони використання змінних:
хіА?0, хіВ?0, і?[1; 4]
0 ? у1?2000
0 ? у2?4000
0 ? у3?1000
Перейдемо до рішення задачі про сплави. Спочатку треба ввести вихідні дані в чарунки робочого листа.
1. Відведіть під змінні хіА, хіВ, і?[1; 4] діапазон чарунок СЗ:D6, а під змінні уі, і?[1; 3] - F3:F5.
2. Введіть:
o у діапазон чарунок G3: G5 - наявні запаси руд;
o у діапазон чарунок Н3:Н5 - ціни за одну тонну руди;
o у діапазон чарунок І3: M5 - характеристики складу руд.
3. В чарунку G9 введіть цільову функцію, яка у даному випадку є функцією масиву. Тому не забудьте завершити її введення натисканням комбінації клавіш ++.
{=220*СУМ (СЗ : Сб) +250*СУМ (D3 : D6) -СУМ (НЗ : H5*F3 : F5 )}
4. В чарунки діапазону С8:С17 введіть ліві частини обмежень, а в D 8: D 17 - праві частини в такий спосіб:
чарунка формула чарунка формула
С8 =C3 D8 =0,7*СУММ(C3:C6)
C9 =C4 D9 =0,3*СУММ(C3:C6)
C10 =D4 D10 =0,5*СУММ(D3:D6)
C11 =D4 D11 =0,8*СУММ(D3:D6)
C12 =D5 D12 =0,2*СУММ(D3:D6)
C13 =D6 D13 =0,5*СУММ(D3:D6)
C14 =СУММ(C3:D3) D14 =СУММ(F3:F5*I3:I5)
C15 =СУММ(C4:D4) D15 =СУММ(F3:F5*J3:J5)
C16 =СУММ(C5:D5) D16 =СУММ(F3:F5*K3:K5)
C17 =СУММ(C3:C6) D17 =СУММ(F3:F5*L3:L5)
Примітка
Чотири останні формули - це формули масивів. Тому не забудьте завершити введення кожної з них натисканням комбінації клавіш ++ +.
Перейдемо до безпосереднього рішення задачі за допомогою засобу Пошук рішення. Для цього:
1. Виберіть команду Сервіс | Пошук рішення. На екрані відобразиться діалогове вікно Пошук рішення.
2. Заповните діалогове вікно Пошук рішення, як показано на рис. 5.7.
3. Натисніть кнопку Виконати. На рис. 5.8 показані результати роботи засобу Пошук рішення.
Рис. 5.7 - Вихідні дані та заповнене діалогове вікно "Пошук рішення"
Рис.5.8 - Результат розв'язання задачі засобами "Пошуку рішення"
Задача про оптимальне планування штатного розпису
Розглянемо задачу оптимального планування штатів. Авіакомпанії "Перманентний рейс" потрібно визначити, скільки стюардес варто прийняти на роботу протягом шести місяців за умови, що кожна з них, перш ніж приступить до самостійного виконання обов'язків стюардеси, повинна пройти попередню підготовку. Потреби в кількості (с.-год.) літного часу відомі і приведені в табл. 5.6.
Таблиця 5.6 - Потреби в стюардесо-годинах у задачі про оптимальне планування штатного розкладу
Місяць Потреба, с.-год. Місяць Потреба, с.-год.
Січень 8000 Квітень 10000
Лютий 9000 Травень 90000
Березень 8000 Червень 12000
Підготовка стюардеси до виконання своїх обов'язків на регулярних авіалініях займає один місяць. Отже, прийом на роботу повинний, принаймні, на місяць випереджати "початок виконання обов'язків на борту". Крім того, кожна стюардеса-учениця повинна протягом місяця, відведеного на її підготовку, пройти 100-годинну практику безпосередньо під час польотів. Таким чином, за рахунок кожної стюардеси-учениці протягом місяця звільняється 100 ч робочого часу, відведеного для вже кваліфікованих стюардес.
Кожна цілком кваліфікованих стюардеса протягом місяця може мати наліт до 150 ч. Авіакомпанія на початку січня вже має 60 досвідчених стюардес. При цьому ні одну з них не знімають з роботи. Встановлено також, що приблизно 10% кваліфікованих стюардес звільняються за власним бажанням за сімейними чи іншими обставинами.
Досвідчена стюардеса обходиться авіакомпанії в $800, а стюардеса-учениця - у $400 на місяць. Необхідно спланувати штат авіакомпанії, мінімізуючи витрати за шість звітних місяців.
Для даної задачі також можна представити математичну модель, але їїзручніше проаналізувати в більш розгорнутій формі. А саме:
1. Відведіть діапазон чарунок В3:В8 під число нових стюардес, прийнятих на роботу із січня по червень (мал. 5.9).
2. В чарунку В2 введемо число працюючих стюардес у грудні.
3. В чарунках діапазону D3:D8 будемо обчислювати число постійно працюючих стюардес у поточному місяці. Для цього
o в чарунку D3 введіть формулу
=В2
o в чарунку D4 введіть формулу
= D3+0.9*ВЗ
o виберіть чарунку D4, розташуєте покажчик миші на її маркері заповнення і простягніть його вниз на діапазон D5:D8. Тепер, в чарунках діапазону D3:D8 будемо обчислювати число постійно працюючих стюардес у поточному місяці.
Рис. 5.9 - Вихідні дані задачі про штатний розклад і заповнене діалогове вікно Пошук рішення
4. В чарунках діапазону ЕЗ:Е8 обчислимо наліт по місяцях. Для цього
o ведіть в чарунку ЕЗ формулу
=D3*$G$12+B3*$F$12
де в чарунках F12 і G12 введений припустимий наліт стюардеси-учениці і працюючої стюардеси.
o виберіть чарунку ЕЗ, розташуєте покажчик миші на її маркері заповнення і простягніть його вниз на діапазон Е4:Е8. Тепер, в чарунках діапазону ЕЗ:Е8 будемо обчислювати наліт по місяцях.
5. В чарунках діапазону F3:F8 обчислимо витрати по місяцях. Для цього
o введіть в чарунку F3 формулу
=D3*$E$12+B3*$D$12
де в ачрунках D12 і Е12 введена зарплата стюардеси-учениці і працюючої стюардеси.
o виберіть чарунку F3, розташуєте покажчик миші на її маркері заповнення, і простягніть його на діапазон F4: F8.
6. Залишилося обчислити сумарні витрати за планований період. Для цього в чарунку F9 введіть формулу
=CУMM(F3:F8)
Переходимо до рішення задачі про складання штатного розкладу за допомогою засобу Підбор параметра.
1. Виберіть команду Сервіс | Пошук рішення.
2. На екрані відобразиться діалогове вікно Пошук рішення. Заповните діалогове вікно Пошук рішення, як показано на рис. 5.9.
Результати розрахунку оптимального штату стюардес приведені на рис. 5.10.
Рис. 5.10 - Знайдене рішення задачі про штатний розклад
Цікавою особливістю цього рішення є те, що фірма в останній місяць планового періоду бере на навчання 17 нових стюардес. Припустимо, що авіакомпанія не так упевнена в майбутніх перспективах і вирішила в червні не брати на навчання нових співробітників. Тоді в поле Обмеження діалогового вікна Пошук рішення треба додати В8=0. Оптимальне рішення при цьому додатковому обмеженні приведе до тимчасового підвищення поточних витрат (рис. 5.11).
Рис. 5.11 - Внесення додаткових умов в поле "Обмеження" діалогового вікна "Пошук рішення"
Рис. 5.12- Результат рішення задачі про штатний розклад при накладанні додаткових умов
ЛІТЕРАТУРА
1. Бухвалов А.В. и др. Финансовые вычисления для профессионалов.- СПб.: БХВ-Петербург, 2001.-320с. ил.
2. Гарнаев А.Ю. Excel, VBA, Internet в экономике и финансах.- СПб.: БХВ-Петербург, 2001.- 816с.:ил.
3. Евдокимов В.В. и др. Экономическая информатика. Учебник для вузов. Под ред. Д.э.н., проф. В.В.Евдокимова. - СПб.: Питер, 1997. - 592с.
4. Згуровський М.З., Коваленко І.І., Міхайленко В.М. Вступ до комп'ютерних інформаційних технологій: Навч.посіб. - К.: Вид-во Європ. ун-ту (фінанси, інформ. системи, менеджм. і бізнес), 2000.- 265 с.
5. Информатика. Базовый курс/ Симонович С.В. и др.- СПб.: Питер, 2000.- 640с.:ил.
6. Карлберг, Конрад. Бизнес-анализ с помощью Excel.: Пер с англ.- К.: Диалектика, 1997.- 448с.: ил.
7. Лук'янова В.В. Комп'ютерний аналіз даних: Посібник. - К.: Видавничий центр "Академія", 2003. - 344с. (Альма-матер)
Loading...

 
 

Цікаве