WWW.REFERATCENTRAL.ORG.UA - Я ТУТ НАВЧАЮСЬ

... відкритий, безкоштовний архів рефератів, курсових, дипломних робіт

ГоловнаІнформатика, Компютерні науки → Транспортна задача - Реферат

Транспортна задача - Реферат


Реферат на тему:
Транспортна задача
Розглянемо ще один приклад застосування засобу Пошук рішення. Фірма MIS, Inc. має 4 фабрики і 5 центрів розподілу її товарів. Фабрики розташовуються в Денвере, Бостоні, Нью-Орлеані і Далласі з виробничими можливостями відповідно 250, 150, 215 і 165 одиниць продукції щодня. Розподільні центри розташовуються в Лос-Анджелесі, Далласі, Сент-Луїсі, Вашингтоні й Атланті з потребами в 160, 180, 150, 200 і 90 одиниць продукції щодня, відповідно. Збереження на фабриці не поставленої в центр розподілу одиниці продукції обходиться в $0.75 у день, а штраф за прострочення постачання замовленої споживачем у центрі розподілу одиниці продукції, але там що не знаходиться, дорівнює $2.5 у день. Вартість перевезення одиниці продукції з фабрик у пункти розподілу приведена в табл. 5.7.
Таблиця 5.7 - Транспортні витрати
Вартість перевезень 1Лос-Анджелес 2Даллас 3Сент-Луїс 4Вашингтон 5Атланта Вироб-ництво
1 Денвер 1.5 2 1.75 2.25 2.25 250
2 Бостон 2.5 2 1.75 1 1.5 150
3 Нью-Орлеан 2 1.5 1.5 1.75 1.75 215
4 Даллас 2 0.5 1.75 1.75 1.75 165
Потреба 160 180 150 200 90
Необхідно таким чином спланувати перевезення, щоб мінімізувати сумарні транспортні витрати.
Примітка
Важливо відзначити, що дана модель збалансована, тобто сумарний обсяг зробленої продукції дорівнює сумарному обсягу потреб у ній, то в цій моделі не треба враховувати витрати, зв'язані як зі складуванням, так і з недопоставками продукції. У противному випадку в модель треба ввести:
- у випадку надвиробництва - фіктивний пункт розподілу; вартість перевезень одиниці продукції в цей фіктивний пункт покладається рівним вартості складування, а обсяги перевезень у цей пункт дорівнюють обсягам складування надлишку продукції на фабриках;
- у випадку дефіциту - фіктивну фабрику; вартість перевезень одиниці продукції з фіктивної фабрики покладається рівної вартості штрафів за недопоставку продукції, а обсяги перевезень з цієї фабрики дорівнюють обсягам недопоставок продукції в пункти розподілу.
Для рішення даної задачі побудуємо її математичну модель. Невідомими тут є обсяги перевезень. Нехай хij - обсяг перевезень з і - ї фабрики в j-й центр розподілу. Цільовою функцією є функція, яка описує сумарні транспортні витрати, тобто
,
де сij- вартість перевезення одиниці продукції з i-ї фабрики в j-й центр розподілу. Крім того, невідомі повинні задовольняти наступним обмеженням:
- невід'ємний обсяг перевезень;
- оскільки модельзбалансована, вся продукція повинна бути вивезена з фабрик, і потреба всіх центрів розподілу повинна бути цілком задоволена.
Таким чином, ми маємо наступну модель:
мінімізувати:
Приступимо до рішення транспортної задачі за допомогою засобу Пошук рішення (мал. 5.13).
1. Введіть в чарунки діапазону ВЗ:F 6 вартості перевезень.
2. Відведіть чарунки діапазону B8:F11 під значення невідомих (обсягів перевезень).
3. Введіть в чарунки діапазону H8.-H11 обсяги виробництва на фабриках.
Рис. 5.13 - Вихідні дані для транспортної задачі і заповнене діалогове вікно Пошук рішення
4. Введіть в чарунки діапазону В13:F13 потребу в продукції в пунктах розподілу.
5. В чарунку В16 введіть цільову функцію
=СУММПРОИЗВ(ВЗ:F6;B8:F11)
6. В чарунки діапазонів G8:G11 введіть формули, що обчислюють обсяги виробництва на фабриках, в чарунки діапазону B12:F12 обсяги продукції, що доставляється, у пункти розподілу. А саме:
чарунка формула чарунка формула
G8 =СУММ(B8:F8) B12 =СУММ(B8:B11)
G9 =СУММ(B9:F9) С12 =СУММ(C8:C11)
G10 =СУММ(B10:F10) D12 =СУММ(D8:D11)
G11 =СУММ(B11:F11) Е12 =СУММ(E8:E11)
F12 =СУММ(F8:F11)
7. Виберіть команду Сервіс | Пошук рішення і заповните діалогове вікно Пошук рішення, як показано на мал. 5.13.
8. Натисніть кнопку Виконати. Засіб Пошук рішення знайде оптимальний план постачань продукції і відповідні йому транспортні витрати (мал. 5.14).
Рис. 5.14 - Оптимальне рішення транспортної задачі
ЛІТЕРАТУРА
1. Бухвалов А.В. и др. Финансовые вычисления для профессионалов.- СПб.: БХВ-Петербург, 2001.-320с. ил.
2. Гарнаев А.Ю. Excel, VBA, Internet в экономике и финансах.- СПб.: БХВ-Петербург, 2001.- 816с.:ил.
3. Евдокимов В.В. и др. Экономическая информатика. Учебник для вузов. Под ред. Д.э.н., проф. В.В.Евдокимова. - СПб.: Питер, 1997. - 592с.
4. Згуровський М.З., Коваленко І.І., Міхайленко В.М. Вступ до комп'ютерних інформаційних технологій: Навч.посіб. - К.: Вид-во Європ. ун-ту (фінанси, інформ. системи, менеджм. і бізнес), 2000.- 265 с.
5. Информатика. Базовый курс/ Симонович С.В. и др.- СПб.: Питер, 2000.- 640с.:ил.
6. Карлберг, Конрад. Бизнес-анализ с помощью Excel.: Пер с англ.- К.: Диалектика, 1997.- 448с.: ил.
7. Лук'янова В.В. Комп'ютерний аналіз даних: Посібник. - К.: Видавничий центр "Академія", 2003. - 344с. (Альма-матер)
Loading...

 
 

Цікаве